Runtime Environments > Serverless runtime environments > Working with serverless runtime environments
  

Working with serverless runtime environments

Work with your serverless runtime environment to edit its configuration, stop and start it, and delete it. Use Administrator to update runtime environments on AWS. Use the Azure portal to update runtime environments on Microsoft Azure.

Edit

Edit a serverless runtime environment to update the environment properties. To edit the platform configuration properties, stop the runtime environment first.
The following table describes the properties that you can edit based on the runtime environment status:
Status
Description
Running
You can edit the maximum number of compute units and the task timeout. The updated values take effect for future tasks.
Stopped
You can edit all properties. After you save the changes, start the runtime environment to run it using the updated values.
Failed
You can edit all properties. After you save the changes, the runtime environment automatically starts using the updated values.
A serverless runtime environment that uses AWS PrivateLink doesn't detect updates to existing resource shares. To update the resource share, complete the following tasks:
  1. 1In AWS, update the resource configurations in the resource share.
  2. 2Generate a new resource share invite.
  3. 3In Administrator, navigate to the serverless runtime environment.
  4. 4Open the Actions menu and select Stop.
  5. 5In the runtime environment properties, specify the resource share ID and append each resource configuration and DNS name to the domain map.
  6. 6Select Save and then select Start.

Stop

Stop a serverless runtime environment to update its platform configuration or to reduce resource usage during periods of inactivity. When a runtime environment stops, it becomes unavailable but it's ready to come back up when you need it.
Before you stop a runtime environment, use Monitor to make sure that no jobs are running in the runtime environment.

Start

Start a serverless runtime environment to bring it back up. Before you run tasks, wait until the runtime environment status is Running.

Clone

Clone a serverless runtime environment to create another runtime environment with a similar configuration. Cloning is useful when you want to set up a runtime environment that's nearly identical to an existing one. For example, a runtime environment that connects to a different subnet or uses a different security group.

Delete

Delete a serverless runtime environment when you don't need it anymore.
Before you delete a runtime environment, complete the following tasks:
  1. 1In Monitor, make sure that no jobs are running in the runtime environment.
  2. 2In Administrator or on the Azure portal, use the Show Dependencies action to view a list of tasks, mappings, and connections that use the runtime environment. If any assets use the runtime environment, navigate to each asset and update the runtime environment that it uses.

Redeploy

Note:
Effective in the October 2026 release, redeploying a serverless runtime environment is deprecated. Informatica intends to drop support for redeployment in a future release. Deprecated functionality is supported, but Informatica intends to drop support in a future release. Informatica requests that you transition to different functionality before the functionality is dropped.
To update a serverless runtime environment, stop the runtime environment, edit it, and restart it. If the runtime environment fails or encounters an error, resolve the error and save the runtime environment to automatically restart it.